Функция =ТЕКСТ - Форматы даты

 

 Друзья, как часто из даты в Excel в формате 17.10.2015 вам бывает необходимо получить отдельно день недели, месяц или год этой даты?

 

Я видел множество людей, которые как только не изощрялись, чтобы найти составные части даты.

Составные части дат могут применяться по разному: от ВПР до сводных таблиц.

 

Для выделения составных частей из определенной даты есть прекрасная функция ТЕКСТ.

Конечно возможности этой функции намного шире, чем просто работа с датами, но на мой взгляд это ее лучшее применение.

 

Предположим, что в ячейке A1 есть значение даты - 17.10.2015.

Формула =ТЕКСТ(A1;"значение из таблицы ниже")

возвращает всевозможные составные части даты и их комбинации.

К примеру, формула =ТЕКСТ(A1;"ММММ") возвращает "октябрь", а формула =ТЕКСТ(A1;"ММММ, ГГГГ") возвращает "октябрь, 2015".

P.S. значения из таблицы чувствительны к регистру.

Надеюсь этот простой инструмент работы с датами упростит вашу повседневную работу в Excel.

М

Отображение месяца в виде числа без начального нуля.

ММ

Отображение месяца в виде числа с начальным нулем, если он необходим.

МММ

Отображение сокращенного названия месяца (янв–дек).

ММММ

Отображение полного названия месяца (январь–декабрь).

МММММ

Отображение месяца в виде одной буквы (Я–Д).

Д

Отображение дня в виде числа без начального нуля.

ДД

Отображение дня в виде числа с начальным нулем, если он необходим.

ДДД

Отображение сокращенного названия дня недели (пн–вс).

ДДДД

Отображение полного названия дня недели (понедельник–воскресенье).

ГГ

Отображение года в виде двузначного числа.

ГГГГ

Отображение года в виде четырехзначного числа.

Источник таблицы - официальный сайт microsoft по поддержке продуктов Office - support.office.com

 

Back to Top